PhoneGap: ¿Sabe qué bibliotecas no se ejecutarán en las plataformas de destino?

Por razones que todavía no entiendo (todavía), hay algunas bibliotecas / paquetes Java que simplemente no funcionarán correctamente (o incluso se ejecutarán) cuando se implementen en un dispositivo Android. Bibliotecas como Guice o Apache Camel.

Al no ser un desarrollador de iOS, .NET o JavaScript, no sé si iPhones, Windows Phones o Blackberries sufren los mismos problemas o problemas similares.

Independientemente, tenemos al menos 1 escenario (Java / Android) donde PhoneGap está generando código para una plataforma de destino que puede no ser ejecutable en esa plataforma. Entonces, pregunto: ¿PhoneGap conoce cada plataforma de destino lo suficientemente bien como para no generar código nativo que no se ejecute en ella?

En otras palabras, Apache Camel (por ejemplo) no se ejecutará en dispositivos Android. ¿Qué sucede cuando uso GWT para compilar una ruta Camel (con puntos finales) en JavaScript, y luego uso PhoneGap para envolverlo y empaquetar un APK? ¿PhoneGap dirá "oye, esto es algo de Camel; no se puede ejecutar en dispositivos Android" y fallará o existe la posibilidad de filtrar código "no ejecutable" en las aplicaciones PhoneGap?

Respuesta 1

No entiendo qué sucede con la instancia de StreamResult. Veo que el objeto Transformer recibe source y streamResult: transformer.transform (source, streamResult); esto transforma ...

Estoy desarrollando trabajo por lotes en java-ee-7 en la parte superior del servidor de libertad. utilizando la API REST para iniciar el trabajo por lotes. El problema aquí es cuando intenté iniciar el trabajo por lotes para el mismo parámetro de entrada, nuevo ...

Este problema es intermitente, ocurre cada pocas horas en un proceso que se ejecuta cada 30 segundos y realiza la siguiente comunicación de red: hay un servidor en una máquina remota escuchando ...

Estoy usando mi clase reportService para generar el objeto JasperPrint que contiene mi informe, luego lo envío a un Servlet y genera el PDF. El problema es que este servlet no está abriendo el ...