Error al cambiar la versión de JDK

He creado un proyecto en jdk 1.6 y android Rev. 20. Ahora he instalado 1.7 para algunas características, pero no acepta. Tenemos que importar el sun.audiopaquete en Java 1.7 que pretendemos usar en Android. Pero me está dando errores. Por favor, ayúdame. Gracias por adelantado.

Respuesta 1

Aquí las mismas preguntas y aquí

Y también paquete de sol no debe usado marque aquí

La solución para su pregunta es

Haga clic con el botón derecho en proyecto -> Propiedades -> Compilador Java -> Marque "Activar configuración específica del proyecto" -> cambie la versión del compilador a 1.6

Respuesta: 2

Lamentablemente, Android todavía no es compatible con Java 1.7. debe encontrar una solución alternativa y no usar este paquete.

para audio, tiene muchas clases integradas y también clases de terceros.

Respuesta: 3

Así que aquí está la situación: recientemente asumí la responsabilidad de una aplicación web Vaadin8 de un ex colega que dejó la empresa, lo que significa que ahora seré responsable del mantenimiento y también de ...

Uso UserService para administrar mis registros (Federado y OAuth - Híbrido). Uso User.getCurrentUser dentro de la aplicación en "varios" lugares (que no son servlets también) para determinar quién es el usuario actual. YO ...

Estoy usando esta estructura de código a continuación desde aquí http://www.koonsolo.com/news/dewitters-gameloop/ para establecer un bucle de juego que se procesa en función de un conjunto de fps pero renderiza / dibuja lo más posible. Cómo podría ...

Uso de enlaces Selenium Java. Estoy tratando de escribir un módulo corto que tomará una captura de pantalla completa de una página del navegador (sé que AShot existe pero no se mantiene y tiene algunos problemas para mí). Como ...