WARN EclipseJavaCompiler Uso de la versión '11' de Java no compatible, asumiendo la última versión compatible '9' cuando se ejecuta AEM 6.5 en Java 11

Cuando ejecuté AEM 6.5.3 en Java 11, noté mensajes de advertencia sospechosos que aparecían en error.log de vez en cuando:

08.01.2020 16:33:06.236 WARN [10.0.2.2 [1578497585926] GET /editor.html/content/* HTTP/1.1] org.apache.sling.commons.compiler.impl.EclipseJavaCompiler Using unsupported java version '11', assuming latest supported version '9'

Parecía una advertencia durante la compilación de JSP, pero forzar la recompilación de JSP no desencadena este WARN. Me pregunto si este es un problema conocido y si puede causar problemas al ejecutar JSP.

Respuesta 1

Supongamos que el usuario selecciona una ruta de archivo, en alguna clase de manejo de GUI. Por lo tanto, recibo una cadena con una ruta de archivo. Ahora, ¿cuál es la mejor práctica para poner el código de apertura / cierre del archivo? ¿Debería ser el camino ...

Estoy escribiendo una clase de Guitar37 donde se asignan 37 teclas a la escala cromática de 110Hz a 880Hz. public static final String KEYBOARD = "q2we4r5ty7u8i9op - [= zxdcfvgbnjmk,.; / '"; // teclado ...

Estoy tratando de escribir lo siguiente solo para mi interés: public void enableComponents (boolean enable) {Component [] components = getContentPane (). GetComponents (); para (int i = 0; i <...

Necesito crear un programa que calcule el cambio que recibiría, pero dice: Excepción en el hilo "main" java.lang.ArrayIndexOutOfBoundsException: Índice 9 fuera de los límites para la longitud 5 ...